|
|
|
|
|
|
|
Not surprisingly, this situation prompted later RFC documents to address these problems. RFC 1305, issued in March 1992, was drafted by David L. Mills of the Electrical Engineering department of the University of Delaware as an update to the Time Protocol for the Net, and describes a rigorous method for establishing time with a maximum error of 50ms. |
|
|
|
|
|
|
|
|
RFC 1305 describes Network Time Protocol (NTP) v3, a very large flyswatter in two respects: |
|
|
|
|
|
|
|
|
Size. The original RFC 868 code runs around 3Kb. RFC 1305 is about one hundred times that size. |
|
|
|
|
|
|
|
|
RFC 1305 achieves a granularity of about 200ps by extending the RFC 868 protocol from 32 to 64 bits. The first 32 bits are compatible with RFC 868; the second 32 bits indicate fractions of one second. Unfortunately, this time resolution is orders of magnitude beyond what is physically possible over the network. |
|
|
|
|
|
|
|
|
Not surprisingly, therefore, RFC 1361 was issued in August 1992 to describe a subset to NTP v3 called Simple NTP, or SNTP. SNTP retains the 64-bit format but eliminates most of the code that addresses packet delays. RFC 1361 is available via ftp at ds.internic.net in the /rfc directory. |
|
|
|
|
|
|
|
|
Solaris Technologies in Los Altos, California, has created a program that uses SNTP. Called WinSNTP, it operates under Windows 3.1 and is available as shareware in the file WSNTP15F.ZIP at sunsite.unc.edu in directory /pub/micro/pc-stuff/ms-windows/winsock/apps. The program works with the NIST time server. |
|
|
|
|
|
|
|
|
NIST can be contacted for further information |
|
|
|
|
|
|
|
|
via e-mail at time@time.nist.gov |
|
|
|
|
|
|
|
|
Network Time Service
Time and Frequency Division Mail Stop 847
National Institute of Standards and Technology
325 Broadway
Boulder, CO 80303 |
|
|
|
|
|
|
|
|
via telephone at (303) 497-3903. |
|
|
|
|
|