| Error Code | Definition |
|---|---|
| 0 | No error / Success |
| 1 | Invalid Function |
| 2 | File Not Found |
| 3 | Path Not Found |
| 4 | Cannot Open File -- Too Many Files Open |
| 5 | Access Denied |
| 6 | Invalid Handle |
| 7 | Storage Control Blocks Destroyed |
| 8 | Insufficient Memory |
| 9 | Invalid Storage Control Block Address |
| 10 | Invalid or Incorrect Environment |
| 11 | Invalid Program Format Attempted to Load |
| 12 | Invalid Access Code |
| 13 | Invalid Data |
| 14 | Insufficient Memory |
| 15 | Invalid Drive Specified |
| 16 | Directory Cannot Be Removed |
| 17 | Cannot Move File to Different Drive |
| 18 | No More Files |
| 19 | Disk Write Protected |
| 20 | Cannot Find Device |
| 21 | Device Not Ready |
| 22 | Device Command Unrecognized |
| 23 | Cyclic Redundance Check (CRC) Data Error |
| 24 | Incorrect Command Length |
| 25 | Cannot Locate Area or Track on Disk |
| 26 | Disk Cannot Be Accessed |
| 27 | Cannot Find Requested Sector |
| 28 | Printer Out of Paper |
| 29 | Cannot Write to Specified Drive |
| 30 | Cannot Read from Specified Drive |
| 31 | Device Not Functioning |
| 32 | Cannot Access File -- Already in Use |
| 33 | Cannot Access File -- Locked |
| 34 | Wrong Disk in Drive |
| 36 | Too Many Files Being Shared |
| 38 | End of File (EOF) |
| 39 | Disk Full |
| 50 | Unsupported Network Request |
| 51 | Remote Computer Unavailable |
| 52 | Duplicate Name on Network |
| 53 | Network Path Not Found |
| 54 | Network Busy |
| 55 | Network Resource or Device Not Available |
| 56 | Too Many Network BIOS Commands |
| 57 | Network Adapter Error |
| 58 | Specified Server Cannot Perform Requested Operation |
| 59 | Unexpected Network Error |
| 60 | Incompatible Remote Adapter |
| 61 | Print Queue Full |
| 62 | No Space on Server to Store Spooled File for Printing |
| 63 | File to be Printed Deleted |
| 64 | Specified Network Name Unavailable |
| 65 | Network Access Denied |
| 66 | Incorrect Network Resouce Type |
| 67 | Network Name Not Found |
| 68 | Too Many Names on Network |
| 69 | Network BIOS Session Limit Exceeded |
| 70 | Remote Server Paused or Being Started |
| 71 | Unaccepted Network Request |
| 72 | Specified Printer or Disk Paused |
| 80 | File Exists |
| 82 | Cannot Create Directory or File |
| 83 | Failure on Interrupt 24 (INT 24) |
| 84 | Insufficient Storage to Process Request |
| 85 | Local Device Name Already in Use |
| 86 | Invalid Network Password |
| 87 | Invalid Parameter |
| 88 | Network Write Fault Error |
| 89 | Cannot Start Another Process Currently |
| 100 | Cannot Create Another Semaphore -- Too Many Already |
| 101 | Exclusive Semaphore Already Owned |
| 102 | Semaphore Already Set and Cannot Be Closed |
| 103 | Semaphore Cannot Be Set Again |
| 104 | Cannot Request Exclusive Semaphore At Interrupt Time |
| 105 | Semaphore Ownership Ended |
| 106 | Insert Disk |
| 107 | Alternate Disk Not Inserted |
| 108 | Disk Locked or In Use |
| 109 | Pipe Ended |
| 110 | Cannot Open Specified Device or File |
| 111 | File Name Too Long |
| 112 | Insufficient Space on Disk |
| 113 | No More Internal File Identifiers Available |
| 114 | Invalid Target Internal File Identifier |
| 117 | Invalid IOCTL Call |
| 118 | Incorrect Verify-on-Write Switch Parameter |
| 119 | Unsupported System Command |
| 120 | Function Only Available Under Windows NT |
| 121 | Semaphore Timeout Expired |
| 122 | Insufficient Data Buffer |
| 123 | Invalid File Name, Directory Name, Or Volume Label |
| 124 | Invalid System Call Level |
| 125 | No Volume Label on Disk |
| 126 | Specified Module Not Found |
| 127 | Specified Procedure Not Found |
| 128 | No Child Processes to Wait For |
| 129 | Application Cannot Run Under Windows NT |
| 130 | File Handle to Open Disk Partition Not Used for I/O |
| 131 | File Pointer Moved Before Beginning of File |
| 132 | Cannot Set File Pointer on Specified Device or File |
| 133 | Cannot Use JOIN or SUBST on Drive That Contains Previously Joined Drives |
| 134 | Cannot Use JOIN or SUBST on Drive That Is Already Joined |
| 135 | Cannot Use JOIN or SUBST on Drive That Is Already Substituted |
| 136 | Cannot Delete JOIN of a Non-joined Drive |
| 137 | Cannot Delete SUBST of a Non-substituted Drive |
| 138 | Cannot Join Drive to Directory on a Joined Drive |
| 139 | Cannot Substitute Drive to Directory on a Substituted Drive |
| 140 | Cannot Join Drive to Directory on a Substituted Drive |
| 141 | Cannot Substitute Drive to Directory on a Joined Drive |
| 142 | Cannot JOIN or SUBST Currently -- Drive Busy |
| 143 | Cannot JOIN or SUBST Drive to Directory on Same Drive |
| 144 | Directory Not Subdirectory of Root Directory |
| 145 | Directory Not Empty |
| 146 | Specified Path is a Substitute |
| 147 | Insufficient Resources to Join or Substitute |
| 148 | Cannot Use Specified Path Currently -- Busy |
| 149 | Cannot JOIN or SUBST Drive Whose Directory is Target of Another SUBST |
| 150 | System Trace Not Specified or Not Allowed in CONFIG.SYS |
| 151 | Incorrect Number of Specified Semaphore Events |
| 152 | Too Many Semaphores Set |
| 153 | List Incorrect |
| 154 | Volume Label Too Long -- Truncated to 11 Characters |
| 155 | Cannot Create Another Thread |
| 156 | Recipient Process Refused Signal |
| 157 | Segment Already Discarded and Cannot Be Locked |
| 158 | Segment Already Unlocked |
| 159 | Incorrect Thread ID Address |
| 160 | Incorrect Argument String |
| 161 | Specified Path Invalid |
| 162 | Signal Is Already Pending |
| 164 | No More Threads Can Be Created |
| 167 | Unable to Lock File Region |
| 170 | Requested Resource Busy |
| 173 | Lock Request Not Outstanding for Supplied Cancel Region |
| 174 | Atomic Changes to Lock Type Not Supported |
| 180 | Invalid Segment Number |
| 182 | Cannot Run Program -- Invalid Ordinal |
| 183 | File Already Exists |
| 186 | Incorrect Flag Passed |
| 187 | Specified Semaphore Not Found |
| 188 | Cannot Run Program -- Invalid Code Segment |
| 189 | Cannot Run Program -- Invalid Stack Segment |
| 190 | Cannot Run Program -- Invalid Module Type |
| 191 | Cannot Run Program Under Windows NT |
| 192 | Cannot Run Program -- Invalid EXE |
| 193 | Invalid Windows NT Application |
| 194 | Cannot Run Program -- Iterated Data Exceeds 64K |
| 195 | Cannot Run Program -- Invalid Minimum Allocation Size |
| 196 | Cannot Run Program -- Dynamic Link From Invalid Ring |
| 197 | Operating System Not Configured To Run Application |
| 198 | Cannot Run Program -- Invalid Segment DPL |
| 199 | Cannot Run Program -- Automatic Data Segment Exceeds 64K |
| 200 | Code Segment Must Be Less Than 64K |
| 201 | Cannot Run Program -- Reallocation Chain Exceeds Segment Limit |
| 202 | Cannot Run Program -- Infinite Loop In Reallocation Chain |
| 203 | Environment Variable Not Found |
| 205 | No Command Subtree Has Signal Handler |
| 206 | Filename or Extension Too Long |
| 207 | Ring 2 Stack Busy |
| 208 | Too Many or Incorrectly Entered Wildcards in Filename |
| 209 | Invalid Signal Posted |
| 210 | Signal Handler Cannot Be Set |
| 212 | Segment Locked and Cannot Be Reallocated |
| 214 | Too Many Dynamic Link Modules Attached |
| 215 | Cannot Nest Calls |
| 230 | Invalid Pipe State |
| 231 | All Pipes Busy |
| 232 | Pipe Being Closed |
| 233 | No Process on End of Pipe |
| 234 | More Data Available |
| 240 | Session Cancelled |
| 254 | Specified Extended Attribute Name Invalid |
| 255 | Inconsistent Extended Attributes |
| 259 | No More Data Available |
| 266 | Copy Cannot Be Used |
| 267 | Invalid Directory Name |
| 275 | Extended Attributes Did Not Fit into Buffer |
| 276 | Corrupt Extended Attribute File |
| 277 | Extended Attribute Table Full |
| 278 | Invalid Specified Extended Attribute Handle |
| 282 | Extended Attributes Not Supported By File System |
| 288 | Attempt to Release Mutex Not Owned By Caller |
| 298 | Too Many Posts to Semaphore |
| 317 | Cannot Find Message in Message File |
| 487 | Invalid Address |
| 534 | Arithmetic Overflow (> 32 Bits) |
| 535 | Process on End of Pipe |
| 536 | Waiting for Process to Open on End of Pipe |
| 994 | Access to Extended Attribute Denied |
| 995 | Operation Aborted |
| 996 | Overlapped I/O Not in Signalled State |
| 997 | Overlapped I/O In Progress |
| 998 | Invalid Access to Memory |
| 999 | Inpage Error |
| 1001 | Stack Overflow -- Recursion Too Deep |
| 1002 | Invalid Message to Window |
| 1003 | Cannot Complete Function |
| 1004 | Invalid Flags |
| 1005 | Unrecognized File System on Disk |
| 1006 | Invalid File |
| 1007 | Cannot Perform Operation in Full-Screen Mode |
| 1008 | Token Does Not Exist |
| 1009 | Corrupt Registry Database |
| 1010 | Invalid Registry Key |
| 1011 | Cannot Open Registry Key |
| 1012 | Cannot Read Registry Key |
| 1013 | Cannot Write to Registry Key |
| 1014 | Successful Recovery of Registry |
| 1015 | Registry Corrupt |
| 1016 | Registry I/O Failed |
| 1017 | Cannot Load File Not in Registry Format |
| 1018 | Illegal Operation on Registry Key Pending Deletion |
| 1019 | Cannot Allocate Required Space in Registry Log |
| 1020 | Cannot Create Symbolic Link in Registry Key Having Subkeys or Values |
| 1021 | Cannot Create Nonvolatile Subkey Under Volatile Parent Key |
| 1022 | Need to Enumerate Files |
| 1051 | Cannot Stop Service Other Services Are Dependent On |
| 1052 | Invalid Control for Service |
| 1053 | No Response to Start or Control Request |
| 1054 | Cannot Create Thread for Service |
| 1055 | Service Database Locked |
| 1056 | Service Already Running |
| 1057 | Invalid Account Name |
| 1058 | Service Disabled and Cannot Be Started |
| 1059 | Circular Service Dependency Specified |
| 1060 | Service Does Not Exist |
| 1061 | Service Cannot Accept Control Messages |
| 1062 | Service Not Active |
| 1063 | Service Cannot Connect to Controller |
| 1064 | Exception While Handling Control Request |
| 1065 | Database Does Not Exist |
| 1066 | Service Error |
| 1067 | Unexpected Process Termination |
| 1068 | Dependency Failed to Start |
| 1069 | Service Did Not Start -- Logon Failure |
| 1070 | Service Hanging in Start-Pending State |
| 1071 | Invalid Service Database Lock |
| 1072 | Service Marked for Deletion |
| 1073 | Service Already Exists |
| 1074 | Service Running Under Last-Known-Good Configuration |
| 1075 | Dependency Service Does Not Exist or Marked for Deletion |
| 1076 | Boot Already Accepted as Last-Known-Good Control Set |
| 1077 | No Attempts to Start Service |
| 1078 | Duplicate Service Name or Service Display Name |
| 1100 | Physical End of Tape Reached |
| 1101 | Tape Access Reached Filemark |
| 1102 | Beginning of Tape or Partition Encountered |
| 1103 | Tape Access Reached End of File Set |
| 1104 | No More Data on Tape |
| 1105 | Cannot Partition Tape |
| 1106 | Invalid Blocksize on Tape |
| 1107 | Cannot Find Tape Partition Information |
| 1108 | Cannot Lock Media Eject Mechanism |
| 1109 | Cannot Unload Media |
| 1110 | Media in Drive Changed |
| 1111 | I/O Bus Reset |
| 1112 | No Media in Drive |
| 1113 | No Mapping for Unicode Character in Target Code |
| 1114 | Dynamic Link Library (DLL) Initialization Failed |
| 1115 | System Shutdown in Progress |
| 1116 | No System Shutdown in Progress |
| 1117 | I/O Device Error |
| 1118 | No Serial Device Successfully Initialized |
| 1119 | Requested Interrupt Request (IRQ) Busy |
| 1120 | Serial I/O Operation Completed By Another Write to Port |
| 1121 | Serial I/O Operation Completed By Timeout |
| 1122 | No ID Address Mark Found on Floppy Disk |
| 1123 | Mismatch Between Floppy Disk Sector ID and Controller Track Address |
| 1124 | Unknown Floppy Disk Controller Error |
| 1125 | Inconsistent Floppy Disk Controller Registers |
| 1126 | Hard Disk Recalibration Failed |
| 1127 | Hard Disk Operation Failed |
| 1128 | Hard Disk Controller Reset Failed |
| 1129 | Physical End of Tape Encountered |
| 1130 | Insufficient Server Memory to Process Command |
| 1131 | Possible Deadlock Detected |
| 1132 | Improperly Aligned Base Address or File Offset |
Used by: GetLastError
Back to the index.