الفريق العربي للبرمجةأرشيف المنتديات · 2000 – 2023
نسخة أرشيفية للقراءة فقط — التسجيل والمشاركة مغلقان، والمحتوى محفوظ كما كان.

delete domain controler from Active directory

مغلق
بدأه jazzman في 2 نوفمبر 2006 · 6 رد · 1,540 مشاهدة · في منتدى الشبكات العام
مشاركة: واتساب X فيسبوك تيليجرام
#1 صاحب الموضوع

i had a problem in a domain controler in one of my branch

and it was a complete failure so i got a new domain server

and i promote it "dcpromo" and name it with xxx-2 and with the same

ip address with the old one .the name of the old one was xxx-1 .and everything is oky now

but the name of the old server still exist in

( directory Schema , DNS , sites ) when i "ping " xxx-1 & xxx-2 it reply with the same IP address

so please anyone can tell me exactly the steps to remove the old server.

but please take care because it is production environment . i don't want to distory anything

so tell me the steps that you are sure it will not impact anything

i trust your experience .

thanks *-)

#2

بص يا سيدي ...

أولا لازم تتأكد انو ال DC اللي عاوز تعملو Remove ما فيش عليه اي Forest Operation Master ... و ازا عليه انقلها او اعمل Siezing لها على ال DC الجديد...

ثانيا انا ما اعرفش ما يحتويه ال DC القديم من يوزر اكاونت و اعدادات و الى اخره ... بس ازا انتا فعليا نصبت ال DC الجديد و مفيش عندك اي مشاكل في انك تشيل القديم ... يعني كل حاجه مضبوطه ... اليوزرز موجودين و الاعدادات من Policy و غيرو عملتها على ال DC الجديد سواء عن طريق Replication او Migration و انتظر منك تفاصيل اكتر عن الموضوع ده.

أزا امورك كلها تمام يبقى تعمل التالي:

على ال DC الهدف (اللي عاوز تشيلو) ... روح على Run و اديها dcpromo ....

و Next و الذي منو لغاية ما يطلعلك خيار Remove لل DC من ال Forest ....

و كمل Next و هيطير لوحدو ...

ملاحظه: لازم يكون حسابك Admin عشان تقدر تضيف او تشيل اي DC على الدومين.

نقطه اخيره ... انصحك بمراجعة الموضوع التالي بالنسبه لل Migration لليوزر اكاونت و ال Policy و ال Shared Files قبل ان تقدم على خطوة Remove Dc ....

It's hard to stay in such ridiculous situation

#3

the problem is that i don't have the old anymore

it is distroyed "failed in mother board & power supply"

i used the replication method not migration method

i replicated all the data from the FSMO to the new domain controler

and i moved the new domain controler to the site & i forced the replication

from the Headoffice Site which contain the master role server to the new domain controler

and the replication succed but it keeps sending me errors on -replmon tool

so every time i checked the replication it sayes that it can't contact the old server xxx-1

that's why i want to remove it from the schema

if you want any further question please ask me

i hope that i explained everything to you

thanks for paying attention

#4

اوكي خلاص كده ...

يبقى اتبع اللي قلتلك عليه ...

اقتباس
على ال DC الهدف (اللي عاوز تشيلو) ... روح على Run و اديها dcpromo ....

و Next و الذي منو لغاية ما يطلعلك خيار Remove لل DC من ال Forest ....

و كمل Next و هيطير لوحدو ...

ملاحظه: لازم يكون حسابك Admin عشان تقدر تضيف او تشيل اي DC على الدومين.

It's hard to stay in such ridiculous situation

#5

السلام عليكم شوف يا اخي عندي رد متواضع جرب ويمكن يمشي الحال

اعمل سرف جديد بتفس الاسم القديم يعني كان السيرفر القديم مازال موجود واعمل dcpromo واعمل له delete

اضحك علي الجهازة يعني ;)

ولما تتخلص منه الغي الجهاز خالص وشيله من علي الشبكة

#6

finaly i found the steps here is the steps i tried and every thing is perfect

the solution

thanks to all people tried to help me

#7

هذه أفضل طريقة

If the demotion failed when you removed AD from a Windows 2000 domain controller (DC) to convert the DC to a member server, try the following approach:


Use regedt32 to navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl\ProductOptions. 
Change the ProductType's data value from LanmanNT to ServerNT. (Use the exact case.) 
Shut down and restart the server. 
Delete the NTDS folder

هذا الموضوع مغلق.

مواضيع مشابهة