ظهرت لي مشكلة
ORA-12154: TNS:could not resolve the connect identifier specified
عند ريط الفيجوال بيسك دوت 10 مع الاوراكل
سبق ونزلت ل 11g express وحقيقي ما عرفت ابني فيه جداول وبعدين نزلت oracle sql developer وبنتيت جداولي فيه
طبعا باتباع التعليمات حرفيا:

Connection Name: xe_manal
user name: manal
password: manal
وبعدين انشئت 3 جداوال
بالبرنامج كتبت:
Imports System.Data.OracleClient
Dim con As New OracleConnection
con.ConnectionString = "User Id=manal;Password=manal;Data Source=oracleSN"
con.Open()وبجثت بقوقل عن الملف
system.data.oracleclient.dll
وبعدين

بس انا ماعندي الملف تحت .net
ولكن رحت لاستعراض واخذت الملف system.data.oracleclient.dll من سطح المكتب
لقيت حلول بمواقع اجنبية بس ما فهمتها لانهم يشرحون للناس اللي اصلا عندهم خبره
مثلا:
اقتباسThe Oracle docs note:
ORA-12154: TNS:could not resolve the connect identifier specified
Cause: A connection to a database or other service was requested using a connect identifier, and the connect identifier specified could not be resolved into a connect descriptor using one of the naming methods configured. For example, if the type of connect identifier used was a net service name then the net service name could not be found in a naming method repository, or the repository could not be located or reached.
The following actions may be appropriate:
If you are using local naming (tnsnames.ora file):
Make sure that TNSNAMES is listed as one of the values of the names.directory_path parameter in the sqlnet.ora Oracle Net profile.
Verify that a tnsnames.ora file exists and is in the proper directory and is accessible.
Check that the net service name used as the connect identifier exists in the tnsnames.ora file.
Make sure there are no syntax errors anywhere in the tnsnames.ora file. Look for unmatched parentheses or stray characters. Errors in a tnsnames.ora file may make it unusable.
If you are using directory naming:
Verify that LDAP is listed as one of the values of the names.directory_path parameter in the sqlnet.ora Oracle Net profile.
Verify that the LDAP directory server is up and that it is accessible.
Verify that the net service name or database name used as the connect identifier is configured in the directory.
Verify that the default context being used is correct by specifying a fully qualified net service name or a full LDAP DN as the connect identifier
If you are using EZCONNECT naming:
Verify that EZCONNECT is listed as one of the values of the names.directory_path parameter in the sqlnet.ora Oracle Net profile.
Make sure the host, port and service name specified are correct.
Try enclosing the connect identifier in quote marks. See the Oracle Net Services Administrators Guide or the Oracle operating system specific guide for more information on naming.
NOTE: While there are many possible causes for the ORA-12154 error, it can also appear in the stack with a TNS-03505: failed to resolve name error indicating a problem occured prior to the server being found.
Also note the similiarities in numbering and content for ORA-12514, which is related to the tns listener service.
