السلام عليكم ورحمة الله
تواجهني هذه المشكلة عند المحاولة للدخول على الـ Procedure Builder
طبعاً بعد الضغط على ( Ctrl+j ) كيف لي من حل لهذه المشكلة ؟؟؟
السلام عليكم ورحمة الله
تواجهني هذه المشكلة عند المحاولة للدخول على الـ Procedure Builder
طبعاً بعد الضغط على ( Ctrl+j ) كيف لي من حل لهذه المشكلة ؟؟؟
الحقيقة أني لم أستخدم الـprocedure builder ولكن مشكلة الtns:nolistener بشكل عام هو أنك لم تكون listener للربط مع الـdatabase ولحل المشكلة تستخدم الـNet configuration assistant بحيث تكون listener يكون الـ port number له نفس الـport number للـ database وفي الغالب يكون 1521
ودمتم
بل يجب عليك تشغيل المستمع من على الخادم، قم بالذهاب الى محرك الدوس، وأكتب الامر الآتي
lsnrctl
وعند تشغيل المستمع أكتب الأمر
start
وسيشتغل معك، ويمكن تطبيق نفس الامرين على اليونكس واللينكس
أخيالعزيز السني
بعد تشغيل المستمع على الخادم .....و بعد ظهور رسالة
php:
Starting tnslsnr: please wait.....
/php:
تظهر بعدها مباشرة هذه الراسلة على نفس شاشةالدوس
php:
Failed to start service, errorr 3.
TNS-12560 TNS:protocol adapter error
TNS-00530: protocol adapter error
/php:
فكيف يمكنني ان اصلح هذا الخطأ ؟؟؟؟؟؟؟؟
لو سمحت توضيح ما إذا كان يمكنك الدخول في المستمع ام لأ، اي هل قبل منك الخادم الأمر الاول الذي ذكرته أم لأ، السؤال الثاني، هل قمت بعمل المستمع أم لأ، الثالث، ما هو اصدار الاوراكل لديك، وأي نسخة منه؟
أولاً : نعم تمكنت من الدخول الىالمستمع ......
ثانياً : لم اتمكن من عمل المستمع حيث انه يظهر لي الخطأ التالي
code2
Failed to start service, errorr 3.
TNS-12560: TNSrotocol adapter error
TNS-00530: protocol adapter error
/code2
ثالثاً : النسخة التي لدي هي 6i
لا جديد ؟؟؟؟؟
أخي، لايوجد نسخة من قاعدة البيانات تسمى 6i، فهذه نسخة من حزمة التطوير developer
حسناً قاعدة البيانات لدي هي 8i ....
هذا الموضوع مغلق.